Windows XP Computing Environment at Neda

PLPC-110102

Last Updated: Author unspecified

Doc. Revision: source unspecified

Neda Communications, Inc.

October 9, 2007

Contents

1 Introduction 3

2 Overview 3

3 Data Backup 4

4 Information Gathering and Preparations 4

4.1 Information Gathering ........................................ 4

4.2 OSMT/LSIP Preparations ...................................... 4

4.3 OS Installation Prepartions ................................. 5

5 Windows XP Installation 5

5.1 Windows Install .................................................. 6

5.1.1 Locating Windows XP Professional SP2 Media .............. 6

5.1.2 Locating Windows XP Home Edition SP2 Media .............. 6
5.1.3 Installing Windows XP ............................................................... 6
5.2 Windows XP Home Edition ........................................................... 7

6 Drivers Install .................................................................................. 7
6.1 Windows XP Network Driver and Configuration .............................. 7
6.2 Windows XP Driver Installation ....................................................... 7
6.2.1 Dell Computers ........................................................................... 7

7 Post Installation Configurations ......................................................... 7
7.1 Folder Options ................................................................................ 7
7.2 MPEG2 Decoder for MS Media Center ............................................ 8

8 Installing Windows Applications ....................................................... 8
8.1 MS Woffice 2007 ............................................................................ 8
8.2 Office 97 ......................................................................................... 9
8.3 Microsoft Office 2000 ................................................................. 9
8.4 Microsoft Outlook Configuration ................................................... 10
8.5 Netscape Communicator 6 ............................................................. 11
8.6 Acrobat Reader ............................................................................. 12
8.6.1 Ghostscript 5.50 / GSview 2.7 ..................................................... 12
8.7 Cygwin b20.1 ................................................................................. 12
8.8 Emacs (From Local Drive) .............................................................. 12
8.9 Pretty Good Privacy (PGP) 6.5.8 ...................................................... 13
8.10 MS-Dev Studio 6.0 ........................................................................ 14
8.10.1 Location in the File Cabinet ...................................................... 14
1 Introduction

This is more a set of notes than a formal document. The spirit of information in here is to provide reminders such that the task at hand can be accomplished faster next time around. Level of detail varies from section to section, depending on who added the notes.

By choice this document is made public so that we can offer the information, policies and procedure to our clients and others.

NO Passwords, Product Keys, License Numbers, etc. should be included in this document.

Those private information is kept as a companion to this document.

Our use of MS Windows is very limited. It is a generic laptop desk-top capability. All server functions are performed with Linux. Our main use of Windows is for line of business applications that are not readily or easily available under Linux. QuickBooks, Quicken and Turbotax are such examples.

See XXX for dual boot Windows/Linux setup.

2 Overview

- Back Up All Data
- Preparations
- Windows Install
- Network Driver Install and Configuration
- Drivers Instalation
- OS Updates
- Windows Configuration (folder options, ...)
- Applications Instalation
- Office Configurations
- Application Data Restoration

3 Data Backup

- Backup important data and documents on Shared Documents

4 Information Gathering and Preparations

4.1 Information Gathering

- Go into BIOS -- F2 right after power on -- on dell machines.
- Bios -> System -> Device Info
  - Look up Video Controller -- eg. 945 GM 1280 by 860
  - Audio Controller -- eg. Sigmatel 9200
- Look up Service Tag

4.2 OSMT/LSIP Preparations

If a new computer/host/laptop (Box):
1. Assign the computer a BoxName.
2. Create an asset file for the Box.
3. Create the LSIP/OSMT item files for the Box. Make Sure ethernet address matches LSIP

If an existing computer/host/laptop (Box):

1. Identify the Computer (Box Name) – i.e. SHAAD.
2. Locate the Asset File for the Box Name.
3. Verify that the LSIP/OSMT item files for the Box.
4. Backup all useful information on the box.

Next, idnetify and locate the following:

1. The Windows Media that will be used.
2. The Windows license that will be assigned to this Box.
3. The Office Media that will be used.
4. The Office license that will be assigned to this Box.

4.3 OS Instalation Prepartions

- Gather required CDs
- Windows XP
- Windows Office
- Dell Drivers CD

5 Windows XP Installation

This section describes the Windows XP Operating System installation procedure in detail.
5.1 Windows Install

- Insert Windows XP CD
- Installation Type: New Installation
- Follow directions, choose language options, etc
- Delete current partitions to free up space
- Admin Password: 3admin[first 3 letters of box name]
EXAMPLE Billy’s admin password is ‘3adminbl’
- Workgroup or Group Domain? No, Workgroup

5.1.1 Locating Windows XP Professional SP2 Media

**Exact Version Number** Windows XP Professional SP2

Media kept in original package at the Windows Shelf. Make sure you put it back there.

5.1.2 Locating Windows XP Home Edition SP2 Media

**Exact Version Number** Windows XP Home Edition SP2

Media kept in original package at the Windows Shelf. Make sure you put it back there.

5.1.3 Installing Windows XP

Name :
Organization :
CD Key :
Computer name : go to Chapter 9 for specific computer.

- Password:

**PART 3. Installing Windows XP Service Pack**

The latest version of Service Pack that we have on our database is Service Pack 5 to patch our Windows XP machine. This Service Pack 5 installation is located in Jamshid. The exact location of this program is in:

XX
5.2 Windows XP Home Edition

6 Drivers Install

6.1 Windows XP Network Driver and Configuration

Use the CD Drivers.

   Use DHCP for everything.

6.2 Windows XP Driver Installation

6.2.1 Dell Computers

Locate the support tag.

   Go to http://support.dell.com, locate the drivers.

   - Insert Dell drivers CD
   - use Dell.com/support to download missing drivers
   enter box service tag (found on the bottom)
   - for INSPIRON 6400,
   video: Intel 945GM Graphics Controller
   audio: SIGMATEL-driver stac 92XXC-major HD audio
   chipset: Intel-driver (Mobil Chipset’)
             Ricoh-driver

7 Post Installation Configurations

7.1 Folder Options

Tools -> Folder Options -> View

[X] Display contents of system folder

[X] Display full path in title bar
7.2 MPEG2 Decoder for MS Media Center

MS Media Center does not include mpeg2 decoder.

For dell computers that is included in Sonic CinePlayer.

Locate the Reinstalling Sonic CinePlayer Software and install it.

8 Installing Windows Applications

Most of these softwares are installed in the computer and are ready to be used by regular user. Some of the applications were setup from the network drive and some of them were installed from the local drive.

The applications that are installed are:

Emacs
Winzip 6.3
Winzip Self Extractor 2.1
Netscape Communicator 3
Netscape Communicator 4.61 (Latest version)
Acrobat Reader
Ghostscript 5.50 / GSview 2.7
Cygwin b20.1
GCC-2.95

8.1 MS Woffice 2007

- Office configuration
- Insert Office CD
- Follow directions, etc
8.2 Office 97

Location in the File Cabinet

A1-04-03

Procedures and Option Selections

1. Put the CD-ROM in the drive.
2. Setup option : Typical.
3. Registration Information:
   - Name :
   - Company :
   - CD-Key :
4. Installation Folder : C:/Program Files/Microsoft Office
5. Click Next to complete the installation.

8.3 Microsoft Office 2000

1. Insert disk 1 of Office 2000 into the CD-ROM
2. Enter user name: Mohsen Banan
3. Enter Company: Neda
4. Enter product key:
5. accept the license agreement, click next
6. select customize
7. Install Office 2000 at C:/MicrosoftOffice2000
8. click next
9. click install now
10. Click no to restart manually (don’t restart)
11. Insert disk 2 of Office 2000
12. Repeat steps 2-6
13. click ok when done
14. Restart the computer
8.4 Microsoft Outlook Configuration

This section will describe the following:

- Setting up e-mail account
- Import/Export Address Book
- Sharing Calendar

Microsoft Outlook E-mail

Here are the step to add/edit the e-mail account in Outlook:

1. Click on the Microsoft Outlook icon on your desktop. If this is your first time running the Outlook program, it will guide you to set up your account. For E-mail Service Option, choose “Internet Only”. Follow the rest of the setup.

2. Click on Tools→Options→Mail Delivery→Accounts→Mail. You can add or edit the existing account. To add new account, click on Add. You can add either Mail (POP3/IMAP) or Directory Services (LDAP).

Outlook’s Address Book

To import/export the existing address book, you can use the import/export tools. Under File, click on Import/Export... and just follow the instruction. You probably need to add this feature by reinstalling the outlook program.

Outlook’s Calendar

The Outlook’s Calendar can be shared in two ways:

- As an HTML file.
  Open the Outlook’s Calendar and then under File, click on “Save As Web Page”
- Publish a Net Folder.
  Other way to share the calendar with other people is by using the net folder sharing.
  1. First of all, you need to add the person’s name which you want to share with. Click on File→Share→Calendar. You probably haven’t install this feature, thus you need to install it first.
2. The “Sharing Calendar” window will pop up and click Next.
3. Next you need to create the list of people with whom you will share the folder. You can add or remove the person on the list and also set the permission.
4. This permission will control whether the person will be able to edit it or just read only, etc.
5. Describe the folder that you share (or just leave it blank).
6. Outlook will e-mail a request for confirmation to everyone on the list. You need to reply to this invitation. This confirmation need to be open with outlook e-mail.
7. Outlook will e-mail a copy of this calendar folder to the people on the list and if someone edit this folder, outlook will also send the updated calendar to everyone on the list as well.

8.5 Netscape Communicator 6

1. Click on My Computer
2. Click on U on Yankee.neda.com\dos\u (U:)
3. Go to Win32-neda-std folder
4. Click on Netscape 6
5. Click on N6Setup
6. Click next at setup screen
7. accept the license agreement
8. Select Browse and set Directory to C:\Netscape
9. Click OK, Click Yes
10. Select Custom and click next
11. Click next and click next again (if the Quality feedback box is checked then unclick it)
12. Set program folder at Netscape6, click next
13. Click next at Download Options screen, select install

After installing the program you must update the address book by doing the following:

1. Open Netscape6 and click on Task-Address Book
2. In the Address Book window, click on File-Import The type of material to import: Address Book.Next.
3. Click on Text then Next
4. Select the CSV file: /usr/devenv/groups/family
5. click next then click ok
6. you must also import the CSV file /usr/devenv/groups/nedastd
8.6 Acrobat Reader

This software is in the U drive on Arash. The location is:

U:/win32-neda-std/acrobatRead-ar40eng.exe

Double click on the icon and the setup program will start.

8.6.1 Ghostscript 5.50 / GSview 2.7

This software is in the U drive on Arash. The location is:

U:/win32-neda-std/ghostscript-gsv27550.exe

Double click on the icon and the setup program will start.

8.7 Cygwin b20.1

The Cygwin tools are ports of the popular GNU development tools and utilities for Windows XP and 9x. They function through the use of the Cygwin library which provides the UNIX system calls and environment that these programs require. A full documentation for this program can be found in Neda’s Public Documents Repository (file:/h7/opt/public/htmlDocs/index.html)

8.8 Emacs (From Local Drive)

Here are the steps in order to run Emacs program from your local drive:

2. uncompressed the programs
3. "tar xvf" them in "d:"  
4. type in mv emacs-19.34.6 emacs
5. Go to Start, Programs, MKS Toolkit, and then go to Korn Shell or you can also use DOS Prompt.
6. type : cd n: – (n is on arash/h6/pcnfs)
7. type : cd emacs/bin
8. type : ./addpm d:/emacs
   The addpm edits the registry and puts the right environment variables in there.
9. type : runemacs.exe
10. After that, go to Start, Settings, and then Taskbar.
11. In the Taskbar, click on Start Menu Programs and then click Add.
12. Command line : d:/emacs/bin/runemacs.exe.
13. Select folder to place the shortcut : Desktop
14. Select a name for the shortcut : Gnu Emacs
15. Right-click on the icon, choose Properties, and then shortcut.
   
   Start in : %HOME%
16. Setting up the HOME Directory
   (a) Click Start, Control Panel, and then go to System.
   (b) In the System Properties, click on Environment.
   (c) In the User Variables, highlighted on the HOME variables and change the value to d:/home/yourname. If there hasn’t been a HOME variable, create the new one.
   (d) Copy u:/mohsen/.emacs to your home directory.
   (e) in ".emacs" replace ”g:/eoe” with ”d:/eoe”
   (f) Testing it by running the Emacs.

8.9 Pretty Good Privacy (PGP) 6.5.8

Install the PGP software. The binary location is in /dos/u/win32-neda-std/PGPFW658Win32.zip. The installation is pretty straight forward. Just follow the on-screen instructions.

1. After installing PGP on your computer, create a private and public key pair. Click on Start—PGP—PGPKeys. The PGP Key Generation Wizard provides some introductory information on the first screen.
2. After finished reading the information, click Next and the wizard will ask you to enter your name and email address.
3. Select a key type, either Diffie-Hellman/DSS (new technology – PGP version 5.0 or later) or RSA (older technology).
4. Select a key size from 1024 to 3072 bits. (1024 bits is considered safe unless you are exchanging extremely sensitive info.)

5. Indicate when your key to expire (0 for Never)

6. Enter your passphrase. Enter the string of characters or words you want to use to maintain exclusive access to your private key. This can include whitespace, symbols, etc.

7. The wizard will begin the key generation process.

8. Specify whether you want to send your new public key to the certificate server or not.

8.10 MS-Dev Studio 6.0

8.10.1 Location in the File Cabinet

A1-03-10

8.10.2 Procedure and Option Selections

1. Put the CD-ROM (Disk 1) in and then click Next to continue.

2. Registration Info:

   User Name:
   Organization:
   CD-Key:

3. Product ID: (was given automatically)

4. Choose Common Install Folder:

   Change To --> D:\DevStudio60\Common

5. Change the installation file to:

   Developer Studio --> C:\DevStudio60\Visual C++ --> C:\DevStudio60\VC\n
6. Choose Custom Installation and click on “Select All”

7. Wait for several minutes for copying the files. Installation complete!

8. You also need to install the MSDN Library. Put the NSDB Library CD-ROM (labeled Disk 1) in and just follow the direction on the screen.

9. Prod ID:
9 Application Data Restore

- go to Shared Documents
- Retrieve backed up documents

10 Office Windows Configurations

See LGCC document.

11 Box Specific Information

11.1 Dell Inspiron

11.1.1 Dell Inspiron 6400

- Start Ubuntu install first to partition the disk.
- Delete any smaller partitions so that the entire disk becomes free space.
- Create new partitions: one for Windows (Fat32), one for Ubuntu (ext3), and one for ‘Swap.’
- Stop Ubuntu install.
- Start Windows installation.
- Change the FAT32 partition to a NTFS partition and continue with the normal Windows installation.
- Return to Ubuntu install.
- Use manual partition to put Ubuntu in the right partition (ext3).
- Continue with the normal Ubuntu installation using section 2.1.3 instructions.
- Return to Windows; insert the Dell drivers install disk and extract the network A15 driver.
- Once network is available, go to Dell.com and download drivers: Audio –Sigmatel Video –Network –Chipset –MPEG decoder

Name the specific drivers that were loaded.

11.1.2 Dell Inspiron 640m

Name the specific drivers that were loaded.

- Video 945 GM
- System Utilities
- Intel Chipset
- Audio